Проблемы с отображением меню

5 года 3 нед. назад #4507 от Anelka
Здравствуйте!

Давно почитываю Ваш сайт - много полезного для себя почерпнула. Спасибо Вам огромное!

Но вот с одной проблемой справиться никак не могу. Суть:

J 1.5.25 + VM 1.1.9 (более поздние версии не устраивают)
Меню стандартное mod_mainmenu (пробовала разные - проблема сохраняется)

Нужно меню следующей структуры:

- Материал
-- Категория ВМ 1
-- Категория ВМ 2
-- Материал
- Материал
-- Материал
-- Материал
И т.п., т.е. все вперемешку.

Все работает отлично, но при открытии страниц ВМ (категорий) выпадающее меню пропадает. Методом научного тыка выяснила, что оно работает, но прячется под страницу категорий ВМ. Игрища с z-index успехом не увенчались. Или не в том файле меняла.

Посоветуйте, плиз - куда копать?

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

5 года 2 нед. назад #4510 от Wedal
Anelka, дайте ссылку на сайт. Посмотрю.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

5 года 2 нед. назад #4514 от Anelka
Сайт пока настраиваю на временном закрытом поддомене. Пароли и явки сбросила на почту.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

5 года 2 нед. назад #4520 от Wedal
Anelka, в одном из файлов, выделенных жирным
components/com_virtuemart/fetchscript.php?gzip=0&subdir[0]=/themes/default&file[0]=theme.css&subdir[1]=/js/mootools&file[1]=mooPrompt.css
есть класс:
.clr {
    clear: both;
    overflow: hidden;
}

Нужно найти его и удалить:
overflow: hidden;

А вообще, делать сегодня сайт на J1.5 и VM 1.1.x - плохая затея. И то и другое вскоре перестану поддерживаться(VM 1.1.x вроде уже перестал)
Спасибо сказали: Anelka

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

5 года 2 нед. назад #4524 от Anelka
Нашла: components/com_virtuemart/themes/default/theme.css

Прибила. Заработало. Спасибо огромное - я бы не догадалась такие параметры рассматривать!

А по поводу версий... Я ставила и крутила вдоль и поперек J2.5+VM2.0. Снесла, т.к. на предыдущих версиях то, что мне нужно, делается проще и дешевле. Т.ч. выбор исключительно прагматичен. Поддержкой же не пользуюсь. Текущий сайт уже 2 года пашет на этих же версиях и не жужжит.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.


Вверх