Куда идем?

Virtuemart для многоязычного сайта

  • ano@hotbox.ru
  • Автор темы
  • Не в сети
  • Осваиваюсь на форуме
  • Осваиваюсь на форуме
Больше
13 года 7 мес. назад - 13 года 7 мес. назад #15 от ano@hotbox.ru
ano@hotbox.ru создал тему: Virtuemart для многоязычного сайта
Уважаемый Виталий, или даже уважаемая аудитория,

не могу найти ответ, помогите пожалуйста: Мой сайт - многоязычный, и это должно относиться и к компонентам. Но нигде нет чёткого объяснения, как завязать виртумарт с джумфиш, или иным подобным компонентом. В списке у джумфиша контент виртумарта для перевода отсутствует. Расскажите как подружить два таких компонента? А если не так, то каким способом делается перевод виртумарта?
Последнее редактирование: 13 года 7 мес. назад пользователем ano@hotbox.ru.

Пожалуйста Войти или Зарегистрируйтесь, чтобы присоединиться к беседе.

Больше
13 года 7 мес. назад #16 от Wedal
ano, в плане многоязычности пока VirtueMart коряв. Уж не знаю зачем, но его разработчики почему то не пошли стандартным путем, который подразумевает использование языковых ini-файлов, а налепили свои собственные. Как подружить VirtueMart и JoomFish написано здесь .

Пожалуйста Войти или Зарегистрируйтесь, чтобы присоединиться к беседе.

  • ano@hotbox.ru
  • Автор темы
  • Не в сети
  • Осваиваюсь на форуме
  • Осваиваюсь на форуме
Больше
13 года 6 мес. назад #59 от ano@hotbox.ru
ano@hotbox.ru ответил в теме Re: Virtuemart для многоязычного сайта
Спасибо, помогло. Правда там много лишнего: автор начинает от установки джумла... Достаточно было просто указать патч-файл для джумфиша, именно только он и нужен:

www.joomfish.net/forum/download/file.php?id=439
...и что его надо распаковать в administrator/components/com_joomfish/contentelements/

Причём по указанной вами ссылке сначала очень напугали что нужна именно связка Джумла 1.5.9 + Виртумарт 1.1.3 + Джумфиш 2.0.2. У меня джумла 1.2.22, вирт 1.1.5, джумфиш 2.0.(), поэтому сначала я разочаровался и уже хотел искать что-то другое..., но рискнул установить патч. Заработало: видимо компоненты и движок должны быть "не менее" этих версий, о чём авторы всегда почему-то умалчивают.

Пожалуйста Войти или Зарегистрируйтесь, чтобы присоединиться к беседе.