Странности Джумлы 1.5

2 года 2 мес. назад #7453 от Григорий К.
Здравствуйте,

У меня возникла странная проблема. Собственно, их две. Одна -- решаемая, а вторую я сам не могу осилить. Но может быть это как то связано...
Проблема № 1:
Для того, чтобы в админке сохранить что либо надо кликнуть 2-3 раза. С первого раза, чаще всего, ничего не меняется.
Проблема № 2:
У меня стоит VirtueMart 1.1
Там есть способ оплаты ROBOKASSA
Там вообще непонятно что происходит. Там где надо ввести пароль и т.д., вместо этого какая то ерунда сама откуда то берется (похоже на PHP код).
Типа < ? ECHO и т.д. >
Это же система сама автоматом прописывает и в соответствующем конфигурационном файле PHP.
Само собой, что в магазине оплата при помощи системы ROBOKASSA не работает (там вместо ссылки на интерфейс Робокассы, я получаю PHP-шный текст, состоящий из разных параметров.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

2 года 2 мес. назад #7455 от Wedal
Григорий, чтобы понять причину того, почему материалы не сохраняются с первого раза, запустите любой web-инспектор(в FF и Chrome это делается с помощью клавиши F12), откройте в нем консоль и воспроизведите проблему. С большой долей вероятности web-инспектор покажет какую-то ошибку скриптов.

По второму вопросу. Если вы видите "< ? ECHO" на странице, значит в коде плагина есть ошибка тегов PHP. Откройте код плагина через любой продвинутый редактор(например, Notepad++) и посмотрите подсветку кода, сравнив ее с любым другим php-файлом. Если в тегах есть ошибка, подсветки будут различаться. Другой вариант - ваш сайт взломан.
Спасибо сказали: Григорий К.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

2 года 2 мес. назад #7456 от Григорий К.
Спасибо за Ваш ответ!

По поводу первого Вашего совета -- приму к сведению. По поводу взлома -- его не было.
По поводу PHP -- я, мягко говоря, в нем не очень разбираюсь. И потом, если была бы ошибка, почему раньше всё прекрасно работало...
Я узнал, что у Джумлы 1.5 есть проблемы с PHP 5.5
Поэтому, раз уж всё равно придется потратить время и силы, то решил перейти на Джумлу 2.5 и Virtuemart 2. Они уже не сырые. Довольно обкатанные. По ним легче получить на форумах советы, да и таким образом я как бы исключаю этот фактор (несовместимости между старой Джумлой и новой версией PHP).

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

2 года 2 мес. назад #7457 от Wedal
Григорий, зачем вам вообще понадобился PHP 5.5 для Joomla 1.5? Странно еще, что проблемы были только со способом оплаты...
Если решите переносить сайт на новые версии, то переносите на Joomla 3 и Virtuemart 3. Joomla 2.5 и Virtuemart 2 тоже уже устарели и не поддерживаются разработчиками. Также примите к сведению, что процесс переноса в данном случае - это миграция. Сайт придется переделывать практически полностью. Если товаров и статей на сайте немного, проще создать новый сайт на Joomla 3 и Virtuemart 3 и вручную наполнить. Говорю по личному опыту.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

2 года 2 мес. назад #7462 от Григорий К.
Это не мне понадобилась PHP 5.5, а Ubuntu не спрашивая меня, по умолчанию, устанавливает новую версию PHP. А я лично, вообще не имел понятия про эти заморочки старой Джумлы, т.к. раньше просто не сталкивался с данной проблемой.
Спасибо за Ваши советы, но пока не выйдут внятные видеокурсы по новым программам, я с ними покамест повременю. Зачем мне поддержка, что они мне будут поддерживать? Если б у меня нормально работал бы старый Virtuemart, так я бы и со вторым не стал бы возиться. Оно мне надо... Моя жизнь не состоит из одного Virtuemart'а, при всем уважении... За три года, что прошли с тех пор как я установил старый, еще пока не было даже ОДНОЙ реальной транзакции. Это, я думаю, важней, чем версии Virtuemart...

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.


Вверх