Дублируетя материал

6 года 2 мес. назад #1810 от acka
Добрый день!

Возникла проблема - во всех пунктах материал публикуется дважды.(Jooomla 1.7)



Объясните, пожалуйста, в чем причина?

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1814 от Wedal
acka, прежде всего, попробуйте посмотреть эту же страницу с другим шаблоном Joomla. Также укажите, что именно это за страница, список материалов категории?

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1817 от acka
С другими шаблонами тоже самое. И разницы никакой - список категории или блог категории.



А не может это быть как-то связано с кнопкой "ДУБЛИРОВАТЬ" в Менеджере модулей: Модули. Может я случайно нажал, но где тогда найти отмену действия?

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1826 от Wedal
acka, если дело не в шаблоне, значит в настройках.
1) Проверьте, что у вас банально не созданы копии всех существующих статей.
2) Посмотрите внимательно настройки материалов(в менеджере материалов кнопка "Настройки" в правом верхнем углу)
3) От модулей это вряд ли зависит, т.к. блог категории отношения к ним не имеет никакого.
4) Если ничего не поможет, можете выслать мне на email доступ к админке - посмотрю(самому уже интересно стало :)).

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1832 от acka

Wedal пишет:
1) Проверьте, что у вас банально не созданы копии всех существующих статей.


Извините, где смотреть? Если в менеджере материалов, то в списке все материалы в единственном экземпляре, а если в другом месте - подскажите где создаются копии,и как их удалять?

Мне тоже интересно. Создал другую базу, поставил туда шаблон, вставил материалы - пока все нормально, но вопрос-то остался. Где гарантия, что все не повторится еще раз?

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1833 от Wedal
acka, на самом деле можно придумать очень много причин почему так происходит. Но причина есть всегда. Какие-то фильтры, модули, дублирование материалов, и.т.д. Если всё же интересен ответ, дайте мне доступ или же пришлите локальную копию сайта. Я посмотрю и скажу в чем была причина. А так приходится гадать на кофейной гуще.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1834 от acka

Wedal пишет: пришлите локальную копию сайта. Я посмотрю и скажу в чем была причина.


Каким образом выслать копию локального сайта? Извините за банальность. Что и куда паковать, и куда высылать?

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1835 от Wedal
acka, если вы используете Denwer, то просто заархивируйте всю папку с ним. Этого достаточно. Мой Email можно найти здесь: wedal.ru/pages/uslugi.html

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1898 от Wedal
acka, открыл ваш сайт. Дело оказалось в том, что у вас была активирована многоязычность. Нужно зайти в менеджер языков, выбрать "Языки контента" и отключить неиспользуемый язык.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1914 от acka

Wedal пишет: acka, открыл ваш сайт. Дело оказалось в том, что у вас была активирована многоязычность. Нужно зайти в менеджер языков, выбрать "Языки контента" и отключить неиспользуемый язык.


У меня стоят только два языка в списке - английский и русский. Мне что, снять галочку с языка, который я не использую (анг.)? Если да, попробовал - ничего не изменилось. Пробовал перезапускать Денвер - ничего - дубль висит.:(

При отключении языка пишет следующее:
1 язык контента успешно снят с публикации.
Внимание! Если вы используете на сайте многоязычность (иными словами, если включен плагин Система - Фильтр языков), то для Языка Сайта по умолчанию должен быть создан и опубликован так же Язык Контента.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад #1919 от Wedal
acka, ну и задали же вы задачку :). Действительно, дело оказалось не в языках. Правда у меня после отключения языка проблема мистическим образом пропала.
Решение оказалось до боли банально - это просто баг Joomla 1.7.0, который проявляется не всегда, а только при стечении каких-то обстоятельств. Решение просто: обновить Joomla до версии 1.7.1. В ней ошибку исправили.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

6 года 2 мес. назад - 6 года 2 мес. назад #1936 от acka
Вообще-то у меня версия 1.7.1. Может где-то глюк проскочил? Попытался обновиться - безрезультатно.
В любом случае, результат есть и задача решена. Вариант решения вопроса известен. Спасибо за помощь!!!

В общем, уже сделал дубль и пытаюсь все настроить, что-то получается не очень...пока.

1. Хотел поставить QuickFaq - для новой версии его нет (рассмотрю варианты);
2. Хотел попробовать JComments - не могу понять, как подключать русский язык и не очень корректно встает (на какой-то вкладке ругается);
3. И беда с установкой com_comprofiler CommunityBuilder CB 1.7 - Пишет: Ошибка загрузки файла на сервер. Скачал с оф.сайта. В чем может быть проблема? Работаю на J1.7. (Создал в этом же разделе отдельную тему: wedal.ru/forum/Oshibki-i-reshenie-problem/1935-ne-zagruzhaetsja-com_comprofiler-community-builder-CB-1.7.html ).

Вот. Если можно что-то подсказать, буду признателен, так как процесс формирования сайта затормозился, а хочется уже получить результат.
Вопросы, конечно, возникают по ходу, но пытаюсь разобраться. Опыт великая штука, а его у меня на данной территории пока маловато.

С уважением.

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.


Вверх