invalid token при отправке формы (joomla 3)

3 года 1 нед. назад - 3 года 1 нед. назад #7063 от hush
Всем добрый вечер

столкнулся с такой ситуацией - при отправке формы появляется белый экран и надпись invalid token

посм в инете - советуют очистить кэш (кэширование на сайте включено)
очистил. в хроме ошибка пропала, а в мазилле - нет (там тоже кэш и кук предварительно чистил)

я так понимаю - дело в кэшировании? но отключать его не хотелось бы - с отключенным сайт гораздо медленнее
что посоветуете?


спасибо
hush

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

3 года 1 нед. назад #7066 от Wedal
hush, причины этой проблемы могут быть разными и их не так просто выявить. Нужно анализировать скрипты. Знаю, что подобное сообщение появляется, когда у пользователя заканчивается сессия, а он пытается отправить запрос(форму), который начал формировать, пока сессия была действительной. Есть и другие причины. Попробуйте вот это:
stackoverflow.com/questions/18971468/joomla-3-invalid-token-error
если вы хорошо разбираетесь в PHP, то можно попробовать поднастроить, но все равно изначально нужно провести анализ и определить причину данного сообщения.
Спасибо сказали: hush

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.

2 года 10 мес. назад #7173 от hush
причина оказалась во включенной gzip - как только отключил - все заработало корректно

вообще c gzip интересная тема - я на некоторых Jфреймворках сталкивался с тем, что некорректно отображаются сниппеты (особенно в фейсбуке) - грешид на разработчиков.

потом где-то вычитал, что нужно отключить gzip _отключил - бинго! красивые и информативные сниппеты на фейсбуке

Пожалуйста Войдите или Зарегистрируйтесь, чтобы присоединиться к беседе.


Вверх